March 21, 2009 · General · Email This Post

Sponsored Link
One more improvement in jaunty is mozilla-gtk-vnc,mozilla-virt-viewer packages for firefox browser

mozilla-gtk-vnc

A VNC viewer widget for GTK+ (mozilla plugin)It is built using coroutines, allowing it to be completely asynchronous while remaining single threaded. It supports RFB protocols 3.3 through 3.8 and the VeNCrypt authentication extension providing SSL/TLS encryption with x509 certificate authentication.
The core library is written in C and a binding for Python using PyGTK is available. The networking layer supports connections over both IPv4 and IPv6.This package contains the experimental mozilla plugin.

mozilla-virt-viewer

A virt-viewer widget for GTK+ (mozilla plugin)The console is accessed using the VNC protocol. The guest can be referred to based on its name, ID, or UUID. If the guest is not already running, then the viewer can be told to wait until is starts before attempting to connect to the console The viewer can connect to remote hosts to lookup the console information and then also connect to the remote console using the same network transport.This package contains the experimental mozilla plugin.

Install these packages using the following comamnd

sudo apt-get install mozilla-gtk-vnc mozilla-virt-viewer

Using These plugins

Now you can put in a web page and have access to virtual machines or other VNC servers directly in your browser.

For gtk-vnc Example


<embed type="application/x-gtk-vnc"
width="800"
height="600"
host="192.168.0.1" port="5900">
</embed>

For virt-viewer Example


<embed type="application/x-virt-viewer"
width="800"
height="600"
uri="qemu:///system" name="something">
</embed>

Sponsored Link

Incoming search terms:

Related posts

4 Comments to “gtk-vnc and virt-viewer mozilla plugins in Ubuntu 9.04 (Jaunty)”

  1. Thanks for knowledgeable post.

    [Reply]

  2. Cybrisbob says:

    Hi All

    I did this but all I see is a black square the size of the vnc window but does not connect or display anything else

    Thanks
    Cybrisbob

    [Reply]

  3. Raza says:

    Dear, When I am going to compile gtk-vnc-0.5.1 with: ./configure –enable-plugin It returns me:

    configure: error: Package requirements (mozilla-plugin >= 1.8) were not met:

    No package ‘mozilla-plugin’ found

    How to get this mozilla-plugin?

    [Reply]

  4. Alee says:

    You need firefox-dev

    [Reply]

Leave a Reply