How to Install Nvidia Driver 304.51 On Ubuntu 2.04 using PPA

Sponsored Link
Nvidia released driver version 304.51 with more bug fixes.

What is new in version 304.51

Added support for the following GPUs:
GeForce GTX 660
GeForce GTX 650
GeForce GT 645M
GeForce GTX 670MX
GeForce GTX 675MX

Added support for the new Quadro Sync board for Quadro Kepler GPUs. See the "Configuring Frame Lock and Genlock" chapter in the README for details.
Fixed an X server crash on X.Org xserver 1.13 when it is compiled without support for DRI2.
Fixed a regression that broke color controls on older X servers.
Fixed a bug that sometimes caused the display layout area of the nvidia-settings control panel to be laid out incorrectly.
Fixed a bug that prevented panning from working correctly after a modeswitch on some X servers with support for cursor constraining.
Gamma ramp and colormap adjustments now apply correctly when screen transformations such as rotation and keystone correction are in use.
Fixed RandR per-CRTC gamma persistence across modeswitches and VT-switches.
Fixed a bug that caused the X server to sometimes hang in response to input events.
Fixed a reduction in rendering performance for core X11 rendering on certain GPUs that occurred in the 290.series of releases.
Fixed a bug that prevented PowerMizer from working correctly on some boards with GDDR5 memory, such as some GeForce GT 240 SKUs.
Fixed a bug that caused OpenGL applications to not animate properly when a rotation or a transformation was applied on some older X server versions.
Enabled FXAA with Unified Back Buffers.
Fixed a bug that prevented the "Reset Hardware Defaults" button in the Display Settings page of nvidia-settings from being activated.

Install Nvidia Driver 304.51 On Ubuntu 12.04

Open the terminal and run the following commands

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Sponsored Link

Incoming search terms:

Related posts

2 thoughts on “How to Install Nvidia Driver 304.51 On Ubuntu 2.04 using PPA

  1. Beware of a current bug if you use Unity / Compiz. Reveal trigger quits working for the launcher.
    Bug 1057000] Re: [Ubuntu 12.04.1/12.10] nVidia drivers 304.51 prevent autohidden Unity launcher from revealing

    [Reply]

  2. Currently the nvidia drivers in this PPA are upto Precise only.

    For Quantal you don’t need a PPA. nvidia v304.51 lies in the Quantal repositories.

    [Reply]

Leave a comment

Your email address will not be published. Required fields are marked *