How to install VLC 1.1.4 in ubuntu 10.04 [New PPA]

VLC media player is a media player, streamer, and encoder for Unix, Windows, Mac OS X, BeOS, QNX, and PocketPC. It can play from many inputs like files, network streams, capture device, desktops, or DVD, SVCD, VCD, and audio CD. It can play most audio and video codecs (MPEG 1/2/4, H264, VC-1, DivX, WMV, Vorbis, AC3, AAC, etc.), but can also convert to different formats and/or send streams through the network.

What is new in VLC 1.1.4 version

A bit after the 1.1.3, an important security issue was discovery in most windows applications, and VLC is affected too. Since security issues matters, here is a new release, targeted for the Windows platform!

* Windows Dll loading security issue, in Qt4 and dmo modules -- VideoLAN-SA-1005
* Fix for folders opening issue on Windows
* Updated translations

Install VLC 1.1.4 in ubuntu 10.04

Open the terminal and run the following commands

sudo add-apt-repository ppa:lucid-bleed/ppa

sudo apt-get update

sudo apt-get install vlc

Sponsored Link

Incoming search terms:

Related posts

14 thoughts on “How to install VLC 1.1.4 in ubuntu 10.04 [New PPA]

  1. If you install vlc 1.1.4 from n-muench ppa there are some broken ffmpeg libs so use the ppa specified in the article

    [Reply]

  2. I have a trouble using add-apt-repository behind a proxy (seems a non-yet-resolved bug), so i used to add repositories editing source.list. Are there any “deb http:// …” way to get this repository (and a way to get its key, too) manually?
    Thanks.
    PD: sorry about my english.

    [Reply]

  3. After installing Vlc 1.1.4, Sopcast-player no longer starts, this is the log from console:

    Traceback (most recent call last):
    File “/usr/share/sopcast-player/lib/sopcast-player.py”, line 1783, in
    pySop = pySopCast()
    File “/usr/share/sopcast-player/lib/sopcast-player.py”, line 371, in __init__
    self.vlc = VLCWidget.VLCWidget(*p)
    File “/usr/share/sopcast-player/lib/VLCWidget.py”, line 28, in __init__
    self.player=instance.mediacontrol_new_from_instance()
    AttributeError: ‘Instance’ object has no attribute ‘mediacontrol_new_from_instance’

    Sopcast-player was installed by this ppa:
    ppa:jason-scheunemann/ppa

    [Reply]

    admin Reply:

    You can try the following options and see

    disabled the 3rd party ppa for vlc
    reinstalled sopcast

    [Reply]

  4. @de reditu:

    I am the maintainer of the lucidbleed ppa. I have a few questions:

    1. Did you have the same problem with vlc 1.1.3 from this ppa? Or did you install this ppa for the first time for vlc 1.1.4?

    2. Lucidbleed ppa uses straight unmodified backports from Maverick. In the case of VLC to work, ffmpeg was backported. If sopcast was relying on the old version of ffmpeg in lucid (0.5.x), upgrading it to the new version in maverick and in the ppa (0.6) may break it. In this case the option is to revert to the older vlc or have the sopcast developer to update the application to the new version of ffmpeg.

    3. sopcast-player is not in the official repos and uses customized low-level libraries, I would recommend getting in touch with the developer inquiring if he tested sopcast in maverick. As I mentioned above, lucidbleed uses the same libraries as maverick.

    [Reply]

  5. It seems sop-cast relies on a python call that is no longer supported in version 1.1.4 of vlc. Recompiling with updated libraries does not seem to fix it. I strongly recommend getting in touch with the sopcast developer.

    [Reply]

  6. All right, it seems this is a very well known problem with sopcast-player and the latest branch version of vlc (1.1.x):

    http://code.google.com/p/sopcast-player/issues/detail?id=43

    Basically the python bindings have changed between version 1.0.x and 1.1.x of vlc. The main developers are aware of it and working on an updated version. So please monitor progress in the above bug report. In the meantime the only viable solution is to revert to the stock version of vlc in lucid (1.0.x).

    [Reply]

    admin Reply:

    Nick

    Thank you so much for your quick response

    [Reply]

  7. VLC 1.1.4 is available from the repository below.

    sudo add-apt-repository ppa:ferramroberto/linuxfreedomlucid

    sudo apt-get update

    sudo apt-get install vlc mozilla-plugin-vlc

    As usual I hope this helps someone.

    [Reply]

  8. ppa:ferramroberto/linuxfreedomlucid for VLC was last updated on 29th August for lucid, I suspect but don’t know that there will be no further updates of VLC from this repository. I am now running VLC 1.1.5 on maverick from ppa:ferramroberto/vlc this also works on lucid. So if you want the latest version add ppa below.

    sudo add-apt-repository ppa:ferramroberto/vlc

    sudo apt-get update

    sudo apt-get install vlc mozilla-plugin-vlc

    As ever, hope it helps.

    [Reply]

Leave a comment

Your email address will not be published. Required fields are marked *