Howto Install E17 Enlightenment Desktop in Ubuntu

Sponsored Link
Enlightenment, commonly referred to as e, is a open source software X window manager primarily for Unix-like computers. Enlightenment focuses on pushing the limits of existing technologies while remaining lightweight, flexible, and beautiful. The project has a long history; the current stable version is e DR (development release) 16, and the unstable developer version is e DR17

Enlightenment Desktop Features

  • Basic options, such as window movement, resizing, and focus
  • Virtual screen settings, such as the number and separation
  • Window, pointer, and ToolTip behavior
  • Sound effects for window operations
  • Special effects for window, desktop, and menu animation
  • Distinct background settings for desktops
  • Extensive ToolTips and pop-up help
  • Keyboard shortcuts for nearly 80 actions, such as window handling, desktop navigation, or cursor movement.

The following procedure will work for Ubuntu Edgy and Ubuntu Feisty

Install E17 Enlightenment Desktop in Ubuntu

First we need to add the repo to our apt sources list

Open your Terminal and type

sudo vi /etc/apt/sources.list

Now you need to add the following lines save and exit the file

## E17 repository “edevelop.org”

deb http://edevelop.org/pkg-e/ubuntu edgy e17
deb-src http://edevelop.org/pkg-e/ubuntu edgy e17

Now we need the gpg key for the repo

wget http://lut1n.ifrance.com/repo_key.asc

sudo apt-key add repo_key.asc

Now we need to update source list using the following command

sudo apt-get update

Now we can install E17 using the following command

sudo apt-get install e17

Now you need to logout from the existing desktop if you want to login in to enlightenment desktop select Sessions--->Enlightenment and click on change session to login

Enlightenment Desktop is Loading

Once it loaded Enlightenment Desktop you should see similar to the following screen

Sponsored Link

Incoming search terms:

Related posts

12 thoughts on “Howto Install E17 Enlightenment Desktop in Ubuntu

  1. instuctions worked great for Ubuntu 7.04.
    Slick instructions, they were on point.

    Thanks! been wanting to take a look at this Enlightenment for a few years now.

    [Reply]

  2. Does probably work for 32bit version of Ubuntu, but no way in 64 bit version. I’ve tried and did not work at all.

    [Reply]

  3. ENLIGHTENMENT E17 ON UBUNTU 9.04

    The site http://xsm.alphagemini.org/E17/repository/

    Has an excellent repository for installing Enlightenment e17 in Ubuntu 9.04

    Ignore the advice about pinning … it will install perfectly. This is the ONLY method that seems to get a fully functioning E17 into Ubuntu 9.04

    All that is required is to add this repository to your /etc/apt/sources.list file

    Add the following line …

    deb http://debian.alphagemini.org/ unstable main

    then sudo apt-get update

    then apt-get install e17 emodules-all

    [Reply]

  4. “then apt-get install e17 emodules-all”
    And … broken dependencies or so.
    ============================================
    The following packages have unmet dependencies:
    e17: Depends: exchange but it is not going to be installed
    Depends: libecore-con-svn-01 (>= 0.9.9.060) but it is not going to be installed
    Depends: libecore-evas-svn-01 (>= 0.9.9.060) but it is not going to be installed
    Depends: libecore-file-svn-01 (>= 0.9.9.060) but it is not going to be installed
    Depends: libecore-imf-svn-01 (>= 0.9.9.060) but it is not going to be installed
    Depends: libecore-input-svn-01 (>= 0.9.9.060) but it is not going to be installed
    Depends: libecore-ipc-svn-01 (>= 0.9.9.060) but it is not going to be installed
    Depends: libecore-x-svn-01 (>= 0.9.9.060) but it is not going to be installed
    Depends: libedbus-svn-01 (>= 0.5.0.060) but it is not going to be installed
    Depends: libedje-svn-01 (>= 0.9.9.060) but it is not going to be installed
    Depends: libeet1 (>= 1.0.0) but it is not going to be installed
    Depends: libefreet-svn-01 but it is not going to be installed
    Depends: libevas-svn-01 (>= 0.9.9.060) but it is not going to be installed
    Depends: libgnutls26 (>= 2.5.9-0) but 2.4.2-6ubuntu0.1 is to be installed
    Depends: libevas-engines but it is not going to be installed
    Depends: libedje-bin but it is not going to be installed
    emodules-all: Depends: emodule-alarm
    Depends: emodule-bling
    Depends: emodule-calendar
    Depends: emodule-configmenu but it is not going to be installed
    Depends: emodule-cpu
    Depends: emodule-deskshow
    Depends: emodule-diskio but it is not going to be installed
    Depends: emodule-drawer but it is not going to be installed
    Depends: emodule-efm-nav
    Depends: emodule-efm-path
    Depends: emodule-emu
    Depends: emodule-exalt but it is not going to be installed
    Depends: emodule-execwatch but it is not going to be installed
    Depends: emodule-flame
    Depends: emodule-forecasts
    Depends: emodule-iiirk but it is not going to be installed
    Depends: emodule-language
    Depends: emodule-mail
    Depends: emodule-mem
    Depends: emodule-moon
    Depends: emodule-mpdule
    Depends: emodule-net
    Depends: emodule-news
    Depends: emodule-notification but it is not going to be installed
    Depends: emodule-penguins
    Depends: emodule-photo
    Depends: emodule-places but it is not going to be installed
    Depends: emodule-rain
    Depends: emodule-screenshot
    Depends: emodule-slideshow
    Depends: emodule-snow
    Depends: emodule-taskbar
    Depends: emodule-tclock
    Depends: emodule-tiling but it is not going to be installed
    Depends: emodule-uptime
    Depends: emodule-weather
    Depends: emodule-winselector
    Depends: emodule-wlan
    E: Broken packages
    =================================================

    [Reply]

Leave a comment

Your email address will not be published. Required fields are marked *