Install pSX emulator on Ubuntu AMD64

Sponsored Link
This emulator fully emulates the Sony Playstation. Compatibility is fairly high, most games I've tried work well.An R3000 debugger is contained which may be of interest to people working on translations.Originally a windows Playstation 1 Emulator, it has recently been ported over to linux.pSX has all plugins built into the emulator, so there is no need to find plugin's and configure them.

Preparing Your System

sudo apt-get install ia32-libs ia32-libs-sdl ia32-libs-gtk

Download pSX emulator Using the following command

wget -c http://mirrors.kernel.org/ubuntu/pool/universe/g/gtkglext/libgtkglext1_1.0.6-2.1ubuntu1_i386.deb

sudo dpkg -x libgtkglext1_1.0.6-2.1ubuntu1_i386.deb libgtkglext

sudo mv -v libgtkglext/usr/lib/* /usr/lib32/

sudo rm -Rv libgtkglext

sudo rm -v libgtkglext1_1.0.6-2.1ubuntu1_i386.deb

wget -c http://psxemulator.gazaxian.com/pSX_linux_1_11.tar.bz2

tar xvf pSX_linux_1_11.tar.bz2

sudo rm -v pSX_linux_1_11.tar.bz2

cd pSX/

Run psx emulator using the following command

./pSX

more details check here

Sponsored Link

Incoming search terms:

Related posts

15 thoughts on “Install pSX emulator on Ubuntu AMD64

  1. everytime i try and download something the password thing comes up… i can’t type anything for my password so i just click enter and then it says wrong password. what do i do?

    [Reply]

  2. Brian, you simply cannot see the password being entered. That’s normal. It’s like the way asterisks come up instead of numbers when entering a pin; it’s so that others can’t see when keys are being pressed.

    [Reply]

  3. javier murillo

    you need to download the bios of the ps2 game your trying to play ( pal , ect ) thepiratebay.org
    has them

    [Reply]

  4. 1st:
    to whomever wrote the guide, thanks for including commands to delete the files downloaded in the install process. No one ever does that…

    2nd: Damez and the rm command
    Dude, take what you read in people’s forum signatures with a grain of salt. If the RM command always destroyed everything ever, why would it be included? rm is a very dangerous command UNLESS you know what you’re deleting. A better rule than “NEVER USE SUDO RM” is “if you see a ‘sudo rm’ command that doesn’t make sense, make sense of it or don’t run it.”

    3rd: the 404 error
    The wget command in the guide gives a 404 error.
    try this one instead:
    wget -c http://ubuntu.interlegis.gov.br/ubuntu/pool/universe/g/gtkglext/libgtkglext1_1.0.6-2.1ubuntu1_i386.deb
    and in the future, if you see a broken link like that, try to find the missing file somewhere else. (google.)

    4th: the bios question.
    To run a game, an emulator needs a b.i.o.s. (which is a file containing the B.asic I.nput and O.utput S.ervices of the system you’re trying to run), and a game (obvisously). Both of these things are heavily protected by copyright, so downloading copies of them is illegal unless you’ve purchased a legal copy of the game/game system. It’s kind of like pot*. It’s relatively safe, but still illegal. This means you can’t go around asking people where to get it. You have to find the bios and games on your own. Consider it the cost of this software.

    *I don’t condone the use of drugs for anything other than metaphors about antiquated laws that are only still on the books because of groupthink. Like how emulation is illegal. $50 for a snes game that cost me $20 when I bought it new? Eff that.

    Take it easy,
    Tails

    [Reply]

  5. ‘sudo apt-get install ia32-libs ia32-libs-sdl ia32-libs-gtk
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Couldn’t find package ia32-libs’

    Thanks brah!

    [Reply]

  6. @tails
    I tried your solution to the 404 error, it says a later version is already installed. So I moved on to the next command and there was no such file apparently.

    Would appreciate if you have you could help out once more.

    THNX

    [Reply]

  7. I’ll take a look at that tonight, but I don’t know how you’re getting a “already installed” error from wget…

    [Reply]

  8. pSX has a tendency to “segfault” if pulseaudio is running. Usually, running
    sudo killall pulseaudio
    before running pSX clears that up, but if it doesn’t, read this forum post, it cleared it up for my install.
    http://ubuntuforums.org/showthread.php?t=1146830

    also, the wget command is outdated. The link is broken, and the synaptic package libgtkglext1 is a newer version.

    [Reply]

Leave a comment

Your email address will not be published. Required fields are marked *