Midori 0.3.0 released and installation instructions included

Sponsored Link
Midori is a web browser that aims to be lightweight and fast. It uses the WebKit rendering engine and the GTK+ 2 interface

Midori Features

* Full integration with GTK+2.
* Fast rendering with WebKit.
* Tabs, windows and session management.
* Bookmarks are stored with XBEL.
* Searchbox based on OpenSearch.
* Custom context menu actions.
* User scripts and user styles support.
* Extensible via Lua scripts.

What is new in midori 0.3.0

Thousand and one bug fixes, that's what this release turned out to be. A long run of tweaks in various places rather than short and explosive.
Kudos to Pawe? for his great work, notably with bookmark import and export, including Netscape HTML import, and a new infobar prompting to
install userscripts and -styles if the User Addons extension is activated.

A rather big move is Launchpad as the new bug tracker. I have tested it and am convinced of the superiour usability over FlySpray and Bugzilla.
And this addresses the frequently raised concern of using a unique bug tracker, so it should be easier to report bugs with an existing account
and a familiar interface. The old bug tracker still exists and will remain in place for a while, but new bugs should be reported at
Launchpad. The code repository and translations remain with Xfce and Midori is still fully usable and supported on it, and dozens of other
platforms. Kudos to Dan and Michael for moving over a huge number of bug reports.

The new default search engine is DuckDuckGo, https://www.duckduckgo.com a slick and powerful engine with a string focus on data privacy and no
logging whatsoever. Midori uses the SSL version out of the box.This change is not automatic for existing configurations, and Google as
well as Yahoo remain available from the menu and as tokens ‘g' and ‘y' respectively.

Problems with ‘,' and ‘.' for link search and inline search with Russian keyboard layouts have been fixed. Options for languages and panel layout
have been simplified. Netscape plugins no longer show up in the Extensions panel due to repeated confusion with users. URIs keep spaces
encoded as %20 to allow copying to other applications. And context menu-related problems have been fixed.

Install midori 0.3.0 in ubuntu

Open the terminal and run the following commands

sudo add-apt-repository ppa:midori/ppa
sudo add-apt-repository ppa:webkit-team/ppa
sudo apt-get update
sudo apt-get install midori

Sponsored Link

Incoming search terms:

Related posts

2 thoughts on “Midori 0.3.0 released and installation instructions included

  1. Very poor – after adding repo ppa:midori/ppa my system is broken ‘ignoring file ‘getdeb.list.bck/ in /etc/apt/sources.list.d/’ as it has an invalid extension – and type ‘://ppa.launchpad.net/midori/ppa/ubuntu’ is an unknown type in line 2 in source list (midori-ppa-maverick.list’ etc….

    basically the system sources can’t be read now.

    [Reply]

  2. Update Manager has the midori and the midori-dbg “greyed out”. I already have the two repositories listed above with midori 0.2.9 installed. I went to Synaptic and discovered this, after marking midori and midori-dbg for upgrade:

    Both now have a grey/black question mark in the Status column.

    Clicking midori, a window states:

    midori:
    PreDepends: dpkg (>=1.15.7.2) but 1.15.5.6ubuntu4.5 is to be installed

    Clicking midori-dbg, a window states:

    midori-dbg:
    Depends: midori (=0.3.0-1~llwkt1) but 0.2.9-1~llwkt1 is to be installed

    Synaptic does still say I have no “broken” packages, so I hope OTHER packages will not be greyed out in the Update Manager window.

    Pity, I do like Midori and hope I can somehow, later, do the upgrade.

    [Reply]

Leave a comment

Your email address will not be published. Required fields are marked *