July 21, 2008 · Networking · 1 comment

rinetd redirects TCP connections from one IP address and port to another, with basic IP-based access control.rinetd is a single-process server which handles any number of connections to the address/port pairs specified in the file /etc/rinetd.conf. Since rinetd runs as a single process using nonblocking I/O, it is able to redirect a large number of connections without a severe impact on the machine. This makes it practical to run services on machines inside an IP masquerading firewall.

Continue reading →

July 19, 2008 · Server · (No comments)

MultiTail lets you view one or multiple files like the original tail program. The difference is that it creates multiple windows on your console (with ncurses). It can also monitor wildcards: if another file matching the wildcard has a more recent modification date, it will automatically switch to that file. That way you can, for example, monitor a complete directory of files. Merging of 2 or even more logfiles is possible. It can also use colors while displaying the logfiles (through regular expressions), for faster recognition of what is important and what not. It can also filter lines (again with regular expressions). It has interactive menus for editing given regular expressions and deleting and adding windows. One can also have windows with the output of shell scripts and other software. When viewing the output of external software, MultiTail can mimic the functionality of tools like ‘watch' and such.

Continue reading →

July 17, 2008 · General · 32 comments

A download manager is a computer program designed to download files from the Internet,unlike a web browser, which is mainly intended to browse web pages on the World Wide Web (with file downloading being of secondary importance).

Continue reading →

July 15, 2008 · Server · 39 comments

atftp is Multi-threaded TFTP server implementing all options (option extension and multicast) as specified in RFC1350, RFC2090, RFC2347, RFC2348 and RFC2349. Atftpd also supports multicast protocol known as mtftp, defined in the PXE specification. The server supports being started from inetd as well as in daemon mode using init scripts.

Continue reading →

July 13, 2008 · General · 21 comments

How to install Pidgin 2.4.3 in Linux Ubuntu 7.04 Feisty Fawn by compiling its source code(to compile Pidgin source code)

Continue reading →