NitroShare – Cross-platform tool for sharing files across a local network

Sponsored Link
NitroShare is a cross-platform tool for sharing files across a local network. After completing the setup wizard, NitroShare discovers other machines on the network running the tool and enables you to send files to them using the application indicator or small widgets on the desktop.

A network file-sharing application that makes sending a file to another machine on the local network as easy as dragging-and-dropping.

NitroShare is designed to be hassle-free in every aspect. Just install the application on any machine running Ubuntu or Windows and you're all set. Each machine should discover all of the other machines on the local network. The application integrates with the operating system, using application indicators on Ubuntu and the system tray on Windows.

NitroShare offers a number of other features, including:

dynamic file compress during transfer to decrease transfer time and bandwidth
CRC checksum generation to ensure file integrity during transfer
full compatibility with clients running on other operating systems
a helpful configuration wizard to guide you through setting up the application on your machines

Install nitroshare in ubuntu

Open the terminal and run the following commands

sudo add-apt-repository ppa:george-edison55/nitroshare
sudo apt-get update
sudo apt-get install nitroshare

Screenshots


Sponsored Link

Incoming search terms:

Related posts

3 thoughts on “NitroShare – Cross-platform tool for sharing files across a local network

  1. “Just install the application on any machine running Ubuntu or Windows and you’re all set.”
    and OS X …
    as I found in https://launchpad.net/nitroshare

    there are houses with Ubuntu and OS X
    [ where windows are for light and fresh air ]

    almost stopped reading at that line

    [Reply]

  2. HI is there any way to get this working with Ubuntu 10.04LTS, I have it running of 2 of the machines in the house it would be great to have it on all only 2 are running 10.04LTS, the problem being Error: Dependency is not satisfiable: libqtcore4 (>= 4:4.7.0~beta1)…..help!!

    [Reply]

Leave a comment

Your email address will not be published. Required fields are marked *