February 1, 2011 · General · Email This Post

Sponsored Link
Padre is a Perl IDE, an integrated development environment, or in other words a text editor that is simple to use for new Perl programmers but also supports large multi-lingual and multi-technology projects.

Our primary focus is to create a peerless environment for learning Perl and creating Perl scripts, modules and distributions, with an extensible plug-in system to support the addition of related functionality and languages and to support advanced developers taking the editor anywhere they want it to go.

Features

* Customizable syntax highlighting for many languages
* Syntax checking for Perl 5 and Perl 6
* Refactoring tools for Perl 5 and Perl 6
* Context sensitive help and code completion
* Beginner-friendly
* Extra features for advanced programmers
* Multi-platform: Runs on Windows, Linux, Mac OS X
* Free and Open Source under the "Perl license"
* Written in Perl 5

Install Padre in ubuntu

Open the terminal and run the following command

sudo apt-get install padre

For ubuntu 10.10 users run the following two extra commands after above installation

wget http://www.eekboek.nl/repo/ubuntu_10.10/libwx-perl_0.9702-1_i386.deb

sudo dpkg --install libwx-perl_0.9702-1_i386.deb

Screenshot



Sponsored Link

Incoming search terms:

Related posts

1 Comment to “Padre – Perl Application Development and Refactoring Environment”

  1. harrykar says:

    In lucid 10.04LTS i can’t install it. All i get is:
    harrykar@harrysas:~$ sudo apt-get install padre
    [sudo] password for harrykar:
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    padre: Depends: libwx-perl (>= 0.91) but it is not going to be installed
    Depends: libwx-perl-dialog-perl (= 0.50.ds1-1) but it is not going to be installed
    Depends: libwx-perl-processstream-perl (>= 0.20) but it is not going to be installed
    Recommends: libformat-human-bytes-perl but it is not installable
    E: Broken packages

    Any suggestion about?
    TIA
    Harry

    [Reply]

Leave a Reply