December 19, 2006 · General · Email This Post

Sponsored Link
The movie players provided in Ubuntu can play back unencrypted DVDs. However, many commercial DVDs are encrypted with a weak algorithm called Content Scrambling System (CSS).You can enable playback of encrypted DVDs with MPlayer, xine and Totem-xine by installing libdvdcss2.

The CSS key sets are licensed to manufacturers who incorporate them into products such as DVD drives, DVD players and DVD movie releases.Most DVD players are equipped with a CSS Decryption module.

Installing libdvdcss2

First you need to install the libdvdread3 package using the following command

sudo apt-get install libdvdread3

Now download the libdvdcss2 library using the following command

sudo /usr/share/doc/libdvdread3/examples/install-css.sh

For Ubuntu 6.10 (Edgy Eft) users use the following command

sudo /usr/share/doc/libdvdread3/install-css.sh

If you want to download libdvdcss2 library manually you can download from here

For AMD64 Users

First you need to install the following packages

sudo apt-get install debhelper build-essential fakeroot

Now download the libdvdcss2 library using the following command

sudo /usr/share/doc/libdvdread3/examples/install-css.sh

For Ubuntu Edgy Users use the following command

sudo /usr/share/doc/libdvdread3/install-css.sh

That's it now Your DVD player should now play back encrypted DVDs.You can ope your Movie player from Applications > Sound & Video

Sponsored Link

Incoming search terms:

Related posts

20 Comments to “Playing encrypted DVDs in Ubuntu”

  1. fil says:

    thanks

    [Reply]

  2. Dan says:

    I got an error when I tried this, and I ended up needing to install some libxine packages using adept…

    [Reply]

  3. Mark Stowe says:

    I have Ubuntu 7.04 Feisty… However, in your instructions, the filepath is wrong. I had to use..
    sudo /usr/share/doc/libdvdread3/install-css.sh
    ..instead. The examples folder was nonexistent.

    [Reply]

  4. vodkaice says:

    Thanks Mark Stowe, this command works on 7.04:
    sudo /usr/share/doc/libdvdread3/install-css.sh

    [Reply]

  5. Andronicus says:

    Thanks Mark Stowe, the command does work on 7.04.

    [Reply]

  6. ScoopJumps says:

    Worked like a charm. Thanks for this article. For your information this was on Ubuntu 6.06

    [Reply]

  7. crypticdb8 says:

    Worked perfectly. THank you.

    [Reply]

  8. Cory says:

    Correction for the 64-Bit Instructions:
    sudo /usr/share/doc/libdvdread3/install-css.sh
    should be used on version 8.04 and probably higher.

    [Reply]

  9. Aaron says:

    8.10 the command is:

    sudo /usr/share/doc/libdvdread3/install-css.sh

    [Reply]

  10. Hello,

    I got commercial DVD playback on my computer working. Thanks a lot! Although I must mention that I also had to use” sudo /usr/share/doc/libdvdread3/install-css.sh” instead, to get things working.

    [Reply]

  11. Chris says:

    Didn’t work for me. Still can’t watch my family guy!

    [Reply]

  12. Chris says:

    Remember to restart after doing this guide! It won’t work until you do so!

    [Reply]

  13. grptrk says:

    Thanks, worked fine for me 4 years after the post :)

    [Reply]

  14. Mark says:

    This doesn’t work for me (Ubuntu 9.04). I just discovered the new version (libdvdread4) is in the Restricted Extras package, which means from this release on you should tell your terminal to do THIS:

    sudo /usr/share/doc/libdvdread4/install-css.sh

    [Reply]

    Sam Reply:

    Thanks a lot man frkin love you, lol your the best works well on newest ubuntu

    thanks also to the site makers

    [Reply]

  15. anonymous says:

    Ubuntu 9.04 does work w/ decrypted dvd w/ that installation. “./install-css.sh” go to that dir. and exec. it. goodluck!

    [Reply]

  16. doc says:

    This works, the case if it doesn’t work is that now there is libdvdread4 instead libdvdread3. so please use sudo /usr/share/doc/libdvdread4/install-css.sh
    instead. It worked for me.
    I’m using Ubuntu 11

    [Reply]

  17. kika says:

    hello :) …i am beginner in using terminal …and i need help… when i wrote sudo apt-get install libdvdread3 …then it wrote me unable to locate…so what to do for it????

    [Reply]

    Lee Reply:

    Thank you doc. newer ubuntu os has libdvdread4. Now I can watch Star Trek!

    [Reply]

Leave a Reply