How to get Atheros AR5007EG or AR242x wireless cards (may be other models) working in Ubuntu 8.10 (Intrepid Ibex)

Sponsored Link
This tutorial will explain how to Atheros AR5007EG or AR242x wireless cards working in Ubuntu 8.10 (Intrepid Ibex).First you need to compile latest ath5k driver using the following procedure.Use one of the following method.

Preparing your system

sudo aptitude install build-essential

This will install all the required compilers.

Method 1

Now you need to download the latest wireless drivers from here using the following command

wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2.6.tar.bz2

Now you have compat-wireless-2.6.tar.bz2 file you need to extract this file using the following command from the terminal

sudo tar -jxvf compat-wireless-2.6.tar.bz2

Move to the directory you extracted in terminal

cd directoryname

Run the following commands

make

sudo make install

sudo make unload

sudo make load

Uninstall drivers

If you want to uninstall cd in to the wireless drivers directory path and use the following commands

sudo make unload

sudo make uninstall

Method 2

if you are on Intrepid and still cannot use wifi with an Atheros card , you need to do two things, 1) install linux-backport-modules and 2) blacklist ath_pci and ath_hal.

To install the backport modules, just search for it on Synaptic or use apt-get or aptitude, it's called linux-backports-modules-intrepid. Then on System/Administration/Hardware Drivers make sure Atheros driver is activated.

sudo aptitude install linux-backports-modules-intrepid

For Jaunty Users run the following comamnd

sudo apt-get install linux-backports-modules-jaunty

To blacklist the old modules, do this:

gksudo gedit /etc/modprobe.d/blacklist

And add the following lines At the bottom of the file save and exit

blacklist ath_hal
blacklist ath_pci

Now you need to reboot your system.

IF after this steps you still cannot make it work, you probably have something left still blacklisting ath5k, thus making it not to load. You should search all the files on /etc/modprobe.d for all lines that had:

blacklist ath5k

And add a # before the start of the line, thus making it into a comment so the above one becomes

# blacklist ath5k

Save and exit the file

I hope this help for some one to fix their wireless problem.

Sponsored Link

Incoming search terms:

Related posts

95 thoughts on “How to get Atheros AR5007EG or AR242x wireless cards (may be other models) working in Ubuntu 8.10 (Intrepid Ibex)

  1. hi!

    my answer is about Method 1>> step (1)

    1) install linux-backport-modules

    how can I install that if I cannot conect to internet my computer?

    [Reply]

  2. hi!

    my older comment was wrong, method 2!!!

    my question is about Method 2>> step (1)

    1) install linux-backport-modules

    how can I install that if I cannot conect to internet my computer?

    [Reply]

  3. Thanks a lot, works great! Madwifi dind’t allow me to connect to WEP connections available at work!

    [Reply]

  4. Doesn’t work. this is what I get :

    trip@trip-eMachines-E510:~$ sudo tar -jxvf compat-wireless-2.6.tar.bz2
    bzip2: (stdin) is not a bzip2 file.
    tar: Child returned status 2
    tar: Error is not recoverable: exiting now

    [Reply]

Leave a comment

Your email address will not be published. Required fields are marked *